Firefox, mozilla fontovi (prikaz web stranica)

Evo mene opet :slight_smile:

Muci me jedan problem vec duze vrijeme, ja pokusavam da rijesim to ali nikako da to sredim.
Problem je u tome da firefox niti bilo koji browser pod linux-om kod mene nece da prikazuje web stranice ni blizu kao sto je to prikazivao firefox pod windows-om, odnosno kao sto je to pokazivao IE.
Al problem nebi bio u tome, ja bi se davno s tim pomirio, j… windows i taj prikaz fontova, ali problem je sto znam da se moze napraviti da se stranice pokazuju kako treba i pod linux-om.
Naime na mom faxu su ljudi pod linuxom podesili mozillu da stranice prikazuje super, ne primjetis razliku izmedju prikaza IE-a i mozille. Kao dokaz tome uradio sam par screenshotova sa svog kompa i sa kompa na faxu. Ovo na faxu radi na Redhatu nemam pojma koja verzija i KDE verzija 3.1. Kod mene je Slackware 10.1.

Naime onaj pravi prikaz stranica mozete pogledati na stranici: http://www.geocities.com/slackshots/ok_fonts/
a onaj losiji prikaz sa mog kompa: http://www.geocities.com/slackshots/nisu_losi/

sami cete primjetiti razliku

eto ako neko zna kako se ovaj problem moze rijesiti neka se javi

hvala na pomoci

Ne kontam, pa kod tebe su bolji fontovi :slight_smile:

(Mozilla sa tvog faksa je bez podrške za antialiased fontove)

Što se tiče firefox-a, samo su ti mrvicu premaleni fontovi. (a i Firefox je “polu GNOME” aplikacija, pa ne pokupi dobro veličinu fontova.)

Hajd ovako, probaj firefox pod GNOME pokrenuti,
pokreni gnome-font-properties, idi na details i naštimaj ispravnu vrijednost za Rezoluciju fontova (dpi vrijednost). Kako ćeš znati “ispravnu vrijednost” za dpi fontaova u odnosu na rezoluciju ekrana? => xdpyinfo | grep resolution

recimo, kod mene je za 1024x768 dpi 78x78, i gnome-font-properties generiše sljedeću ‘~/.Xresources’ datoteku:

Xft.dpi: 78
Xft.hinting: 1
Xft.hintstyle: hintfull

P.S. Ako želiš koristiti postavke za GNOME/GTK aplikacije i kada koristiš drugi window manager ili desktop okruženje, trebaš imati pokrenut ‘gnome-settings-daemon’ (ovo se stavi u nekakvu autostart skriptu ili slično).

hvala Adise,

Ma jesu moji bolji kad se vako gleda, ali fazon je sto kad se jedna stranica gleda pod mojim fontom izgleda malo drugacije, nemogu sad naci ni jedan primjer, ali sretao sam da npr. fontovi kod mene prelaze okvire tabela ili sl. a na IE-u ili mozilli sve je OK. U tome je fazon.
Ok znam da je vamo na onim screenshotovima, na onim boljim, iskljucen anti-aliasing, ali kad ga kod sebe iskljucim, to je katastrofa, jedva sta procitat mozes.

Probao sam ovo sto si napisao u vezi s gnome-om, ali vjerovao ili ne razlike nema nikakve. Pretpostavljam da bi pod gnome-om trebalo sve da izgleda sada OK, ali nije vec je potpuno isto.
Malo sam trazio po netu i pise da ko fol treba biti freetype enabled kod kompajliranja firefoxa,a ja kad sam kod sebe sad pogledao (about:buildconfig) to je disabled.
Jos jedna stvar, mozda je bitna zaboravio sam reci, kopirao sam fontove od windows one osnove arial, tahoma i sl. i sa njima se malo popravio prikaz, tj. ovaj sada trenutni, a prije je bila jos veca katastrofa.

nemam pojma, cudno je.

mala dopuna, evo sad sam se ulogovao na KDE, cini mi se da je malo bolje.
al samo jedna stvar ne kontam, nemogu nigdje da nadjem gnome-settings-deamon, sa ‘s’ ima samo gnome-session-…

ako ima jos koji nacin da se fontovi poboljsaju pisite, ako ne, nije lose ni vako, sta se moze.

tnx anyway

Samo instaliraj Windows fontove na Linux
http://corefonts.sourceforge.net/

I ja sam tako odradio kopirao fontove sa xp u ne znam tacno koju lokaciju i koristim te fontovo, nesto oko 40 mb.

Detaljno objasnjenje je na:
http://forum.lugbih.org/viewtopic.php?t=1524

Ako pak preferiras font-aliasing, preskoci dio o rekompajliranju freetype-a i u
local conf dodaj:

<alias>
   <family>sans-serif</family>
   <prefer>
      <family>Helvetica</family>
   </prefer>
</alias>

PS.
nemoj zaboraviti ni .gtkrc-2.0 fajl.

P.