Mail on the login

sigurno imate problem da ne znate ko je i kad na systemu :slight_smile: onda imate vise nego taj problem ipak evo rijesenje

dodaj te na kraju /etc/bashrc sledece

echo ‘login on’ hostname who date| mail -s "login on hostname who|awk '{print $1}'" root

root izmjenite sa username ili email adresom i to je to , od sada ce svaki login biti mailan a user nemoze to da sprijeci, moguci break in tako vam moze biti signaliziran :slight_smile:

Like

Ja godinama koristim haman pa isto

A isto imam i socket monitor, koji obavjestava kad se digne neki od portova

#LSM - port check
*/10 * * * * root /usr/local/sbin/lsm -c >> /dev/null 2>&1

http://www.rfxn.com/projects/linux-socket-monitor/

A zar ne može korisnik kucati “ssh hostname /bin/sh” i tako zaobići izvršavanje bashrc-a ?

Ma ovo je samo informativno… al’ kao i vecina stvari se moze zaobic’

I ja sam to mislio, samo nece moci sa /bin/sh na Linux sistemima jer je /bin/sh samo link na /bin/bash. Na BSDu /bin/sh je poseban shell.

Ali mislim da bi moglo sa:

EDIT: Probao, nemoze, sta vise nece uopste da execute bilo koji shell zadan sa ssh. :\

EDIT2: Ipak radi, samo sto ne dobijemo prompt pa mi je izgledalo kao da shell nije executed ali je ostalo sve normalno. Znaci moze se zaobici. :slight_smile:

dobro primjeceno, naravno ali onda ima zato /etc/pam.d/sshd i /etc/default/locales tu mozes definirati rules za mail on login i def enviroment
bez obzira sta ovaj startao ili brzi workaround

u /userhome/.profile

if [ “$BASH” ]; then
if [ -f ~/.bashrc ]; then
. ~/.bashrc
else
. ~/.bashrc
fi
fi

@Asm1r, ovaj workaround to rijesava ali opet

ok, promislim ispobam, rijesim :slight_smile: iako je vec kroz workaround rijeseno odradicu to u pamu kao optional

Ne treba dirat PAM.
Dalje to sto si naveo osim sto nije bas eleganto rjesenje, uopste ne rijesava problem.
Ako pogledas postojeci /etc/profile vidjeces nesto slicno tome sto si naveo sto se da izbjeci sa noprofile flagom.

Kako bi trebalo biti uradeno je sa /etc/ssh/sshrc, gdje dalje mozemo koristiti $SSH_CONNECTION ili $SSH_CLIENT sto nam moze dati detaljniji report. :slight_smile:

man 8 sshd
man 5 sshd_config

PS:
/bin/sh po defaultu ima norc flag tako da je Vedran bio upravu, my bad. :slight_smile:

[quote=Asm1r]Ne treba dirat PAM.
Dalje to sto si naveo osim sto nije bas eleganto rjesenje, uopste ne rijesava problem.
Ako pogledas postojeci /etc/profile vidjeces nesto slicno tome sto si naveo sto se da izbjeci sa noprofile flagom.

Kako bi trebalo biti uradeno je sa /etc/ssh/sshrc, gdje dalje mozemo koristiti $SSH_CONNECTION ili $SSH_CLIENT sto nam moze dati detaljniji report. :slight_smile:

man 8 sshd
man 5 sshd_config

PS:
/bin/sh po defaultu ima norc flag tako da je Vedran bio upravu, my bad. :)[/quote]

naravno da nije elegantno ali je brzo :wink: i sigurno rijesava problem :wink:
isto tako i i /bin/sh kao i sve moguce opcije /bin/basha i dalje email ide :wink:

PAM ne dirati !!?
pa zasto je je pam tu nego da auth korisinika i prosljedi dalje i naravno da tu idu direktive i da je to ispravan put!

u tvom stilu man pam.d :slight_smile:

/etc/ssh/rc ili sshrc su samo po pitanju SSH sta je sa lokalnim pristupom :wink: ili se ti uspijes i lokalno ssh ulogati :slight_smile:

a sto se tice no profile flaga evo ti dokaz bar na Debianu/CentOSu :slight_smile: za ostale ne garantujem :slight_smile:

ssh client

ssh server

u svakom slucaju vazi deviza prvo kazes hop pa onda pad na glavu, znaci protivteza bez elaborata i argumenata je ono khhhmmhhhhh :),

no nebitno sutra cu ufatiti vremena za pam.d/ nebitno dali ssh ili lokalno

Nisam mislo da ne treba dirati PAM generalno, vec ne treba dirati u ovo slucaju, jer bi to bilo neprakticno.

Dalje , kako man bash kaze, noprofile flag izbjegava profile fajlove. Tako je kod mene (Arch Linux), ne znam zasto kod tebe nije taj slucaj.

Za /etc/ssh/sshrc nije tacno da je samo za client, vec i za sshd iako sshd ima svoj config i naravno da se mogu local login preko ssh, “ssh localhost”.

Na slikama si uradio noprofile ali nisi norc. :stuck_out_tongue:

btw imageshack je nekeko spor i ima previse reklama, omploader.org je cool imas i cmd line linux tool za upload.

[quote=Asm1r]Nisam mislo da ne treba dirati PAM generalno, vec ne treba dirati u ovo slucaju, jer bi to bilo neprakticno.

Dalje , kako man bash kaze, noprofile flag izbjegava profile fajlove. Tako je kod mene (Arch Linux), ne znam zasto kod tebe nije taj slucaj.

Za /etc/ssh/sshrc nije tacno da je samo za client, vec i za sshd iako sshd ima svoj config i naravno da se mogu local login preko ssh, “ssh localhost”.

Na slikama si uradio noprofile ali nisi norc. :stuck_out_tongue:

btw imageshack je nekeko spor i ima previse reklama, omploader.org je cool imas i cmd line linux tool za upload.[/quote]

Neprakticno!?

mozda nisi primjetio od pocetka post, radi se uopste o loginu u system znaci lokalni login kao i remote, da vjerujem ti da na lokalni login prompt uspijes se spojiti putem ssh :wink:
Znaci ako je rijec uopste o loginu na system a ovaj je ovisan o pam.* ide dalje /etc/profile pa /etc/bashrc kao onda naravno definirani shell za korisnika

da “man bash” kaze za .bash_profile ne za globalni /etc/profile koji vazi za sve izbjegavo ih ili ne znaci ovaj gore workaround mozes ubaciti i u /etc/profile
i no escape email pici u svakom slucaju :slight_smile:

uradio sam kao sto sam naveo sve opcije kao i /bin/sh cak i sa /bin/dash i opet tvrdim da ne funkcionise, mrsko mi je bilo ljepiti slike

kod Archa funkionise :slight_smile: onda imaju blagi problem sa poimanjem login procesa i sigurnosti :slight_smile: a kod mene nije slucaj vec default logika i sljedjenje standarda auth i login procesa kako on treba da bude

evo i sa -norc --noprofile

ssh client

ssh server

hvala za tip u vezi omploader

Arch, login problem O.O

Evo i tebi screenshot, sa lijeve strane local ssh login :P. sa desne man bash gdje eksplicitno kaze koje fajlove noprofile flag ignorira.

U slucaju kad se radi o local pristupu i hoces da znas trenutno ko se logovo, PAM config je opravdan, al’ ne znam zasto ti to treba, nvm. :slight_smile:

hahah znaci tebi je local login na tty i ssh na lokalhost isto tako da mozes umjesto useranme ubaciti ssh@localhost ma bravo decko :), shvatas li ti ironiju u mojoj zezi wooow

drugo hvala za bespotrebni screenshot mozes ici od toga da znam man napamet i dokazao sam ti u proslom postu da to ne pije vode

ucini sebi uslugu pa procitaj moj post ispocetka ja zelim da znam ko se prijavi i lokalno i remote i to ovo gore cini i sprijecava bilo kakve -rc --nopofile /bin/sh ili ko zna koje stvari email uvijek ide

P.S posto nevolim gubiti vrijeme na ovakav bla bla molim sledeci put profesionlanu argumentovanu dokazanu protivtezu a ne nesto rekla kazala a ja i objasnio i dokazao i jos mi neko ljepi man bash :))

Vidi ti kazes “ili se ti uspijes i lokalno ssh ulogati” ja pokazao moze, sad ne shvatam niakavu ironiju.

Kazes noprofile ne ignorira ~/.profile i /etc/profile ja ti sliko man bash koji navodi suprotno i rekao da je kod mene taj slucaj ti i dalje negiras jer to na tvojoj massnini nije tako lol. I onda kazes navedi profesionalnu i argumentovanu dokazanu protivtezu, pa sta jos da uradim.

Al’ hajd nek ostane na ovom, jer nemamo o cemu pricat. Nemoj sta zamjerit . :stuck_out_tongue:

PS: Zaboravih reci, ovaj drugi if/else nema bas puno smisla zar ne. :smiley:

if [ "$BASH" ]; then if [ -f ~/.bashrc ]; then . ~/.bashrc else . ~/.bashrc fi fi

ja sam napisao “na lokalni login prompt uspijes se spojiti putem ssh” ako je to za tebe ssh localhost onda zaista nemamo o cemu pricati al ovaj put bez jezika :slight_smile:

try use drop , ja ne kazem ja sam pokazao da od ignoriranja sa --noprofile i dalje stize email, ali ok od sada cemo drugacije sa pojedinim

Nah, napisao si “ili se ti uspijes i lokalno ssh ulogati” i ja se logova lokalno preko ssh. al hajd nejse. :stuck_out_tongue:

I ja sam reko kod mene --noprofile radi ocekivano i onako kako je dokumentirano al neces ti da cujes jer nije tako kod tebe i odmah je problem do Arch Linuxa.

Bitno je da si ti se naljutio. :slight_smile:

ma nisam es upste naljutio al nevolim gubljenje vremena na prazne i suplje rasprave pogotovo kad idu u licnom smijeru, al ok i ja nekad provociram sorry:)

rijec je o monitoru usera na systemu odnosno samoj login proceduri ajmo malo o tome breanistromati bez licnjaka pa cemo vidjeti kako debian/arch to radi

redosljed
boot>grub>krernel>initrd>init>inittab>sysinit>rcX.d>mingetty>login prompt>passwd

getty i login procedura local process

ovdje je malo tezi redosljed jer je proces opsiran i trebala skica ala visio ali ide

def bez PAM

/etc/passwd/ > /etc/shadow
/etc/issue
/etc/profile
/etc/login.defs (iscitava defautni shell koji je definisan /etc/passwd u i env koji ide iz .bashrc)
/etc/limits
/var/log/wtemp
/var/log/btmp

PAM login proces takodje korisit gore navedene confs ali preuzimajuci proces auth starta
/etc/pam.d/login
/etc/pam.d/auth
/etc/pam.d/account
/etc/pam.d/passwd
/etc/pam.d/session

poslije ili sam login logina

/etc/profile
def shell (by default definisano u /etc/paswd) recimo da je bash onda ide
/etc/bashrc
$HOME/.bash_profile
$HOME/.bash_login
$HOME/.profile

znaci to bi bio pregled def lokalnog logina /etc/profile je default i kod debiana je def env za sve shell-ove tako da to objasnjava zasto ignorisanje basha ne funcionise u ovom slucaju po pitanju jer --noprofile dodiruje $HOME/.bash_profile ali ipak sam /etc/profile je parent za login i env tako da bi jedan od workarounda bio u samom /etc/profile definisati tj dodjeliti bash i iscitavanje env per default sto to debian i radi

slijedi nastavak nakon cigare za remote login :slight_smile: