Wakeup ne radi


#21

ok, javim za sat vremena tad cu opet imati taj laptop


#22

Iz recovery-a:
mount -o remount,rw /dev/sdaX - uspjelo
zatim rmmod fglrx - uspjelo
/etc/acpi/sleep.sh - nesto je ispisalo nisam stigao vidjeti ali je uspjelo.

wakeup opet ne radi! Izgleda da nije do grafike?


#23

Izgleda.
Mozemo jos probati sa dodavanjem

u kernel cmd line za slucaj da je problem sa kompatibilnosti linuxa i biosa, za Grub2 imas GRUB_CMDLINE_LINUX ili GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash” mozes dodati navedeni text u bilo koju od ove dvije varijable pa update Grub, (zaboravih koja je ono komanda za Grub update).
Vise mi nis ne pada na pamet. :\


#24

pade mi slucajno na pamet pa probaj i ovo: acpi=force
u mom slucaju stari laptop nije htio da se ugasi, stane na system halted. Nakon dodavanja ove opcije u lilo.conf procepi.


#25
...
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" acpi_os_name="Microsoft Windows NT"
GRUB_CMDLINE_LINUX=""
...

Jel ovako dobro, posto se sistem zaglavi i ne mogu nikako pokrenuti, isto tako i recovery mod. Pa sam tu liniju zakomentarisao tarabom pomocu live cd-a. Gdje da dodam acpi=force


#26

uradi ovako :

...
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_os_name="Microsoft Windows NT""
...

Za acpi=force, vjerujem da je acpi uredu inace nebi nikako mogao suspend ali pokusaj za svaki slucaj sa:

... GRUB_DEFAULT=0 #GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=10 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" GRUB_CMDLINE_LINUX="acpi=force" ...


#27

http://ubuntuforums.org/showthread.php?t=1348427
inace, ja koristim lilo, jer mi je jednostavniji za konfigurisanje.
Update: Asmir bio brzi.
Update2: jedan s askubuntu kaze da je rijesio probleme s sleepom tako sto je obrisao pm-utils.


#28

[quote=Asm1r]uradi ovako :

...
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_os_name="Microsoft Windows NT""
...

milly@Presario-CQ61:/etc/default$ sudo update-grub
[sudo] password for milly:
/usr/sbin/grub-mkconfig: 12: /etc/default/grub: Windows: not found

[/quote]

Sad cu probati sa acpi = force i da obrisem pm-utils kako reznor kaze


#29

Ni GRUB_CMDLINE_LINUX=“acpi=force” ne radi, niti GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi=force”. Tj grub se izgenerise ali nista vezano za standby se nije promjenilo.

Probao sam obrisati pm-utils koji je sa sobom povukao jos neke pakete sto mi se odma’ nije svidjelo al reko 'ajd nek uradi. Nakon restarta, paf! ne moze se ulogovati u graficko okruzenje. Ukacam pass i opet me vrati na login, probam guest usera isto. Odem u konzolu napravim novog usera sa adduser i ne moze ni on. uradim sudo apt-get install pm-utils i on se instalira ali naravno ne povuce one pakete koje je odnjeo sa sobom u uninstalaciji. f**k! Sad je sve sjebano. Izvinite na vulgarnosti al ovo me izludi. Bice reinstall i redovan update i nadati se da ce neki update ovo popraviti (kod mene na susteu je tako bilo samo od sebe).


#30

Ma nemoj reinstall (ja sam ostao bez cijele /usr particije pa sam uspio sve napravit). Trebao si prvo vidjeti sta zavisi od pm-utils, al nebitno sad. Program koji zavisi od pm-utils je upower, a programi koji zavise od upower su:

gdm
gnome-control-center
gnome-power-manager
gnome-session
gnome-settings-daemon

Tako installiraj ponovo ove i jos sta ako zafali (pogledaj aptov log sta si sve izbriso), kada fixas to sve ako nisi probaj ovo sa

Ako i dalje mislis da je do pm-utilsa mozes probati suspend i bez pm-utils al da ga ne brises, tj mozes direktno koristiti acpi (tako je radim jer je brze ali uglavnom vazi da je pm-suspend bolje rjesenje). Komanda za suspend bez pm-utils:

EDIT: Nevidjeh da probao si sa acpi_os_name. :\


#31

[quote=Asm1r]
EDIT: Nevidjeh da probao si sa acpi_os_name. :[/quote]

Jesam probao i to, to je u prvom odgovoru na tvoj prijedlog. Nije ni to pomoglo. Da, mislim da su to ti paketi koji su otisli koje si napisao. Sutra sve probam pa javim.


#32

Ok vratio sam pakete. Procitao iz log-a i sad sistem radi. Probao sam ovaj metod iznad i opet sve isto. Sta jos uraditi?


#33

Bubuntu izgleda kao zmaj :slight_smile:

sto se tice Gruba i acpi podesi ovako:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux”

update-grube

Fakticki imas suspend preko user (uswsusp tolools kao s2ram s2disk) ili kernel space( pm-suspend pm-hibernate) ako hoces userspace kao ja onda ti treba uswsusp

Nakon instalacije ispobaj

s2ram
ili
s2disk

Po defaultu /etc/uswsups.cof uzima swap paticiju da na njoj napravi shanpshot

Greska moze biti do modula ali i graficki efekata, pokusaj u init 1 preci pa testiraj tamo


#34

[quote=die7]Bubuntu izgleda kao zmaj :slight_smile:

sto se tice Gruba i acpi podesi ovako:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_osi=Linux”

update-grube

Fakticki imas suspend preko user (uswsusp tolools kao s2ram s2disk) ili kernel space( pm-suspend pm-hibernate) ako hoces userspace kao ja onda ti treba uswsusp

Nakon instalacije ispobaj

s2ram
ili
s2disk

Po defaultu /etc/uswsups.cof uzima swap paticiju da na njoj napravi shanpshot

Greska moze biti do modula ali i graficki efekata, pokusaj u init 1 preci pa testiraj tamo[/quote]

Will do tomorrow! Thx.


#35
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Ne radi ali je ovaj put malo duze svjelio led od hdd-a prilikom resume-a, ali se opet nije probudio

Kako koristim s2ram jer kod mene

milly@Presario-CQ61:~$ sudo s2ram
Machine is unknown.
This machine can be identified by:
    sys_vendor   = "Hewlett-Packard"
    sys_product  = "Presario CQ61 Notebook PC"
    sys_version  = "0396100000010D10000000000"
    bios_version = "F.15"
milly@Presario-CQ61:~$

#36

Probaj;


#37

bas sad nesto gledam i to potvrdjuje moju misao da je acpi istog lose odradjen ako je suspend bas potreban ima i za to lijeka ali da se razumijemo ovo ti moze zeznuti notebook posteno , ovdje je rijesenje

Pogledja prvo imali update od BIOSa novi pa updataj
pogledaj ovo
http://ubuntuforums.org/showthread.php?t=1036051


#38

[quote=die7]bas sad nesto gledam i to potvrdjuje moju misao da je acpi istog lose odradjen ako je suspend bas potreban ima i za to lijeka ali da se razumijemo ovo ti moze zeznuti notebook posteno , ovdje je rijesenje

Pogledja prvo imali update od BIOSa novi pa updataj
pogledaj ovo
http://ubuntuforums.org/showthread.php?t=1036051[/quote]

Ovde kaze

UPDATE: The kernel dev’s will no longer use the patch to enable custom DSDT files for Karmic 9.10 and beyond. Jaunty 9.04 is the last version this will work on. You are urged to file a bug report for DSDT errors. Jel ovo znaci da se ne moze vise koristiti uopste ili sta?

Jos nesto da pitam. Prije 3 -4 dana sam izvadio bateriju iz tog laptopa, posto stalno stoji na istom mjestu, pa rekoh da je malo ustedim. Znaci laptop radi, samo na punjacu (znam koliko to nije dobro). E sad me zanima da li je to moglo uticati na ove fix-eve koje ste mi slali u zadnje vrijeme pa da zato nisu radili?


#39

[quote=Asm1r]Probaj;

Probao sam i to cim sam vidjeo da moze --force :smiley: ali je isto, zapravo ode na sleep ali se ne budi.


#40

Nisam niti znao da pm ima poseban log.

Postaj ovdje relevantni dio istog. :smiley: